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Topcon Office V10 Release Notes 
 

The following new additions/revisions have been made to Topcon Office v10.0. 

Please take time to read the release notes. They contain information about the following: 

• New Features 
• Feature Enhancements 
• Issue Resolutions 

 

Information 
System Requirements: 
Operating System 

Microsoft Windows 11 (64-bit version) 
Microsoft Windows 10 (64-bit version) 
 

Processor Speed 

2GHz Core2 processor or higher 
 

RAM 

2GB RAM or more recommended 
 

Memory 

Local hard drive space of 2GB or higher recommended 
 

Computer Resolution 

1280x1024 display resolution 
 

Internet Connectivity 

Can be required by some functionality 
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New Features and Improvements 
 

Timestamp support for Points 

Timestamps are a point property that are assigned when 
points are created or imported. During Import of points, if 
timestaps are already assigned, they will be used instead. 
Timestamps can be used for better organisation of data 
providing the user with knowledge of when the data was 
collected or created. 

o Points created will adopt a timestamp property. 

o Timestamps can be viewed in the Point Property 

Manager but cannot be edited. 

o Import/Export of timestamps support if they are 

recorded from MXL, MJF, TP3, PT3. 

o Point Timestamp is supported in reports (eg: List Data) 

o Edit> Select by support select by timestamp range. 

o Modify> Edit Points updated to include a Timestamp 

column (right click header to configure) 

 

Projections and Geoids 

• Import/Export custom projections from EPSG resources 

• Added coordinate projections for Rocky Mountain Tribal Coordinate Reference System 

• Added Brazil Geoid hgeoHNOR2020 

 

Import/Export 

• File> Import/Export - Topcon GT Finland (.gt) added 

• File> Import/Export – MJF. Additional linestyles support added: 

DashDotDot, LongDash, Center, Phantom, Phantom2, Phantom3.  

Note: Renamed DotDash to DashDot. 

• File> Import ASCII - updated to support drawing units - 

USInch/Inch/cm/mm 

 

Property Manager 

• Property Manager updated to support TAB key to move to next input field.  

Up/Down arrows on keyboard can also be used to change fields in dropdown menus. 

• Property Manager> String - Convert to Polyline defaults elevation to elevation of start point.  
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Area (Polygon) Selection  

Users can make selections on the screen by dragging (left t right or right to left) window 

selection. We have introduced a new selection method to create an Area selection without the 

need to create a Polygon entity. 

o Area Selection - Hold ALT key when clicking the first point to draw an area selection. 

o Area selection must be closed back to the start point and cannot intersect itself. 

o Areas drawn Clockwise will selection objects that are completely inside the area. 

o Areas drawn Anti-Clockwise will select objects that are completely and partially inside the 

area. 

  

 

Edit Menu 

• Edit> Select By/Deselect by - updated to support Arrows/Dimensions 

• Edit> Select Similar - updated to support Arrows and Dimensions 

 

View Menu 

Right click context menu updated to include "Set Current Layer" (from View menu) when a 

single object is selected, to make the object layer active. 

 

Insert Menu 

• Insert> Add Line with Adjustment. Adds an angle 

constant to the bearing entered when creating 

lines. The Angle constant will hold per job for the 

session. 
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• Added Insert> Circle> 3 points - Pick 3 points along the circle circumference to create a 

circle. 

• Insert> Polygon/Boundary prohibits self-intersecting linework while drawing the 

polygon/boundary.  

• Insert> Text - Crtl+V will paste text from clipboard 

 

Modify Menu 

• Modify> Edit String to be modeless and dockable. 

 
 

• Modify> Offset> Offset to specific position by 

mouse click – allows to pick on the survey view 

instead of entering an offset distance. This may be 

used in combination with snap modes or can be an 

arbitrary position on the screen. 

• Modify> Reduce String points - in addition to retain 

points based to keep its geometry, the routine has 

been improved to support retention of points 

based on intervals spacing. New setting for straight 

and curved spacing added. 
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Inquiry Menu 

• Inquiry> List Data - Polygon list updated to include layer name. This can be configures in the 

Report Configuration. 

 

Roads/Corridor 

• Corridor> Cross Sections - "Quick" option checkbox added for quick visual display of the 

cross section drawn using active DTMs in the job. It does not require existing 

alignment/string/linework or assignment of DTM to be displayed Quick Cross section does 

not compute volumes. 
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• Roads and Resurface current Station/Chainage field updated to support manual entry of the 

station/chainage for easy searching and setting. 

 
• Design> Pavement Check Report - added L/R or -/+ configuration for Offsets 

 

Drawing Editor 

• Drawing Editor> Settings> Plot settings (Hot button): 

o Removed Contour settings tab from Drawing Editor> View> Plot settings. DTM Settings 

such as DTM colour, Contours, labels Colour Fill will always use the settings set in the 

Survey module. This helps support the ability to set different colours for Contour labels 

for different DTMs.  
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o Display settings tab for DTM added. This will list all the DTMs and provide control to 

turn on/off DTM settings. By default the DTM setting (DTM/Contours/Labels/colour fill 

etc) will copy and set the settings (on/off) from Survey module when the drawing was 

created.  

o The DTM table is also configurable (right click header) whereby the columns can be 

hidden if not required. This configuration is saved in the program and will hold until the 

user changes these settings.  

 

o Grids display tab moved to "Grid" tab.  

o Moved Alignments and North Point display check box to the "General " tab. 

• Insert> Text> Keyword - new keyword $USDATE added for MM/DD/YYYY date format 
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Surface Menu 

• Surface> Compute Volumes - added support for volume computation with Point Clouds 

even without a DTM. 

o Volume computation can be calculated between DTMs, Planes, Level (set 

elevation) and Point Clouds. 

o Optimised volumes computation for improved efficiency and speed to help 

further support when computing with Point Clouds.  

 
 

• Improved creation of CF DTM to stop creating too many and in some cases incorrect 

triangles.  

• Reinstate Add Triangles/Delete Triangles/Delete by line/Swap Triangles under Surface 

menu. These options will operate on the current DTM.  
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• Optimised speed for Add Triangles Delete Triangles and Swap Triangles. 

• Surface> Point Cloud> Create DTM from Point Cloud 

o Restricted Point Cloud DTM creation from tiny triangles (<2mm will no longer be 

created).  

o Using Grid decimation, the Accuracy denotes a horizontal distance (approx. grid 

accuracy). 

 

• Surface> Spot Elevation 

o "No Difference" field added when 2 DTM's are used and the difference between the 

2 is zero. This allows user to enter text into the field (eg: "Zero", "On Grade" etc) or 

kept blank if not required. 

o Removed checkbox from label Prefix/Suffix section. If no Prefix/Suffix is needed, 

keep these fields blank. 
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3D View 

• Improved 3D view for better navigation control 

o View> 3D View - Improved for better orbit/rotation functionality. 

o The 3D view will rotate around the center of all visible objects on the screen. 

• Settings> Program settings> Preferences> Sync 2D|3D Split View - this checkbox will 

synchronise the Survey and 3D split view so that both views retain the same zoom and pan 

ratios when navigating in 2D (Survey) or 3D view. 

 

3D View selection highlight reinstated to display as OBJECT colour when highlighted  

 

• 3D View updated to support Plane display within its boundary extents if present  

• Updated 3D view to display slope arrows smaller  
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Resurface Module 

• Resurface> Alignment> Update Survey - will 

save labels into separate layers. 

• Resurface> Alignment> Update Survey - 

Label transfer improved to support 

nominated station intervals (blank field 

denotes all stations) 

 

 

 

 

• Resurface - Profile> Reports improved to prompt for string to report and upgraded to 

customized reports 
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ADAC 

• Multiple selection supported for Features tree list (left column) to allow for multiple 

record selection and deletion. 

• Spot Levels/Contours support - individual points or a window selection can be made to 

add Spot Levels in bulk. Any Spot Level point already added will override existing 

records. 

• Changed grades to not display negative. 

• Stormwater Pits depth_m value calculated (SurfaceLevel_m - InvertLevel_m) 

• Tooltip added for Geometry Pick fields. 

•  stormwater_wsud_points, stormwater_wsud_polyline added 

• Added OpenSpace ActivityLandscapeEdging, StormWater EndStructurePolyline, 

Transport RoadSafetyBarriers, Transport PramRamps, Transport Bridges 

• Updated polygon hatching to not be displayed when "Show defined data" is ON if 

"Shade selected Polygons" is OFF in preferences. 
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Fixes 
• Switching background black/white colour using the toggle next to hot button to also 

update the highlight colour, similar to preference settings. 

• View> Background Image> Delete - added message to confirm deletion 

• View> Bing Maps support was temporarily unavailable. Fixed by Microsoft subscription 

settings. 

• Added support for transparent (alpha channel) when importing TIFF files as background. 

• Insert> Background image - image not displaying during inserting (file specific) 

• View> Background image - Multiple edit background image transparency reinstated 

• Insert> Image fixed to display image object as solid. 

• Roads/Corridor - fixes issues with templates not applying completely for loop 

alignments in some cases. 

• File> Drawing Editor - PDF Vectors no longer displayed if present. 

• File> Export PDF from Drawing and Survey - fixed issues with polylines exporting as a 

solid fill. 

• Drawing Editor - Modify> Move - offset/direction input fixed to hold in confirmation 

dialog 

• Library> ACAD Layer definition/translation tables fixed to store more than 32 characters 

for the layername. 

• File> Export DWG optimised speed when there are too many polygons. 

• Edit> Data Clean up - optimised for speed 

• File> Import DGN - fixed error in cases where linestyle definitions are overly complex 

• File> Import DGN - updated to read cell headers as blocks 

• Insert> Background image - Fixed inserting Geotiff background images being too slow 

and slowing program 

• File> Import - string names updated to remove any space at the end of the string name 

• Export TP3/GC3 - fixed Control Point descriptions not been held during Export 

• Insert> Point> Sideshot - Right cilck> Set back bearing fixed. If back bearing is set, the 

subsequent points can use a turned angle by entering "T" and the angle to turn. 

• Insert> Create Entity fixed point name not holding if changed 

• Insert> Create Entity - Autofill checkbox removed. 

• Modify> Offset - fixed string not holding segments parallel to original in some cases 

• Modify> Rotate - some options were not holding the value entered (rotation/scale) in 

next dialolg. 

• Modify> Edit Entity - Polylines updated to support remove nodes 

• Point Cloud - Create Points and Create DTM fixed Accuracy setting fixed when the Point 

Cloud has been scaled using Georeference. 
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• Surface> Point Cloud> Create DTM from Point Cloud - fixed issue with DTM creation 

having too small triangles (<2mm will no longer be created). Using Grid decimation, the 

Accuracy denotes a horizontal distance (approx grid accuracy). 

• Fixed text position being reverted after editing text in Property manager. 

• Inquiry> Linear Distance - removed redundant Layers and Point checkbox 

• Reports - Feet and Inches setting supported 

• Surface> Compute Volumes - report preview was not displaying in some cases. 

• Resurface: Design> Average Level - updated to avoid ripples in contours displayed for 

some job cases. 

• DTM Colour FIll slope settings is now saved int he job 

• Surface> DTM Editor - improved speed of delete triangles 

• Improved DTM Contours missing is some loop cases 

• Surface> Batch volumes fixed error when computing between 2 different jobs 

• Elevations in DTM's were not displayed in the status bar sometimes if triangles were 

very skinny. 

• Surface> Create Enclosing boundary fixed to support lines (not just strings) when using 

Tight Boundary> By linework. 

• Takeoff - updated Over excavate area calculations 

• Translate/Rotate fixed to work using the old command from the toolbar 

• Fixed flashing of data when adding data in 3D view 

• Progress bar to display above TO window only, this was not happening in some cases 

• Fixed Takeoff calculations when an over excavate area also was a subgrade 

• Drawing Editor - Print to PDF was not printing image objects in some specific cases 

• File> Import PDF - fixed ruler guides not displaying 

• File> Export to DWG - fixed issue with symbols not displaying original colour 

• Edit Alignment - fixed crash on Insert Before IP 

• File> Import DWG - fixed issue of not reading road data in specific cases 

 

 

 


